Website

Incident Report for Spotlight Service Status

Resolved

This incident has been resolved.
Posted Mar 20, 2026 - 14:35 GMT

Update

We are continuing to investigate this issue.
Posted Mar 20, 2026 - 14:28 GMT

Investigating

We're currently experiencing issues with user accessing Spotlight.com and are investigating as a matter of urgency
Posted Mar 20, 2026 - 14:01 GMT