Filmmakers missing media and incomplete credit dates

Incident Report for Spotlight Service Status

Resolved

This incident has been resolved.
Posted Apr 22, 2026 - 09:29 BST

Investigating

We’re aware that some Filmmakers members are experiencing missing media and incomplete credit dates on their profiles. This is being investigated as a matter of urgency and we’ll provide an update here as soon as we have one.
Posted Apr 21, 2026 - 09:29 BST