Profile edits and update speed

Incident Report for Spotlight Service Status

Resolved

This incident has been resolved.
Posted Jul 26, 2024 - 14:21 BST

Investigating

We are currently aware of and investigating an issue on the site. While this occurs any profile changes or updates may take slightly longer than usual to process.
Posted Jul 26, 2024 - 11:18 BST