Issue: Some users may be experiencing a lag on Spotlight
Incident Report for Spotlight Service Status
Resolved
This incident has been resolved.
Posted Apr 17, 2024 - 14:54 BST
Investigating
We are currently investigating the issue. We will continue to monitor any reports of system errors.
Posted Apr 16, 2024 - 15:21 BST