Website issue: Error Impacting Suggestions
Incident Report for Spotlight Service Status
Resolved
This incident has been resolved.
Posted Apr 15, 2024 - 17:04 BST
Investigating
We are currently investigating an issue impacting agents making suggestions and casting professionals viewing suggestions
Posted Apr 15, 2024 - 15:16 BST