Reset Password / Sign in issues

Incident Report for Spotlight Service Status

Resolved

This incident has been resolved.
Posted Apr 17, 2026 - 15:16 BST

Investigating

We are aware of an issue affecting some of our members trying to reset their password. This may also be affecting some members trying to sign in via Filmmakers. This is being investigating as a matter of urgency.
Posted Apr 16, 2026 - 14:21 BST