Issue with submission of suggestions by agents
Incident Report for Spotlight Service Status
Resolved
This incident has been resolved.
Posted Feb 15, 2021 - 12:03 GMT
Investigating
We're aware of an issue some agents may be experiencing when trying to submit suggestions. We're working on resolving this issue urgently.
Posted Feb 15, 2021 - 11:35 GMT