Breakdown suggestions
Incident Report for Spotlight Service Status
Resolved
This incident has been resolved.
Posted Nov 28, 2024 - 13:16 GMT
Investigating
We are aware of an issue agents may be experiencing suggesting clients for breakdowns. Our team are investigating this as a priority and we hope service to be restored as normal shortly.
Posted Nov 28, 2024 - 13:07 GMT