Card payments
Incident Report for Spotlight Service Status
Resolved
This incident has been resolved.
Posted Jul 02, 2024 - 19:14 BST
Investigating
We are currently experiencing an issues with payments and are unable to take card payments online or over the phone. We are working closely with our partners to get this resolved as soon as possible. Please bear with us while we investigate this further.
Posted Jul 01, 2024 - 11:58 BST