Agents are currently unable to submit clients
Incident Report for Spotlight Service Status
Resolved
This incident has been resolved.
Posted Nov 13, 2019 - 10:12 GMT
Investigating
We are aware that agents may currently be unable to submit clients - we're looking at resolving this issue urgently.
Posted Nov 13, 2019 - 09:25 GMT