Online membership renewal and reactivation not currently available
Incident Report for Spotlight Service Status
Resolved
This incident has been resolved.
Posted Jun 17, 2021 - 13:35 BST
Investigating
Due to essential maintenance with our third party provider, renewing or reactivating your membership online is not currently available. You can still pay for your membership by card by calling us on 020 7437 7631. Please note our Membership Support team are not available until 11am. We apologise for any inconvenience.
Posted Jun 17, 2021 - 10:17 BST