Log in issues
Incident Report for Spotlight Service Status
Resolved
This incident has been resolved.
Posted Oct 18, 2019 - 09:49 BST
Investigating
We're aware that some subscribers may be being occasionally logged out of Spotlight. We're working on resolving this issue.
Posted Oct 17, 2019 - 12:49 BST