Essential maintenance work on the Spotlight site
Incident Report for Spotlight Service Status
Resolved
This incident has been resolved.
Posted Nov 21, 2019 - 09:35 GMT
Identified
We'll be carrying out essential maintenance work from 7:30pm this evening (20/11/2019). Performer members will not be able to renew their membership during this time. Normal service will resume tomorrow morning. Apologies for any inconvenience.
Posted Nov 20, 2019 - 16:39 GMT