Members currently unable to reinstate or renew online
Incident Report for Spotlight Service Status
Resolved
This incident has been resolved.
Posted 9 days ago. Sep 09, 2019 - 11:34 BST
Investigating
We are currently experiencing issues with our systems which means members are unable to reinstate or renew online or over the phone. Our team are investigating the problem currently.
Posted 9 days ago. Sep 09, 2019 - 11:32 BST