Membership issues
Incident Report for Spotlight Service Status
Resolved
This incident has been resolved.
Posted Jan 22, 2020 - 09:17 GMT
Monitoring
We are sorry, but due to essential maintenance, renewing or reactivating your Spotlight membership or subscription online is not available at the moment. It will be back up and running tomorrow morning. Apologies for any inconvenience
Posted Jan 21, 2020 - 21:24 GMT