Membership reinstating or renewing currently unavailable.
Incident Report for Spotlight Service Status
Resolved
This incident has been resolved.
Posted 18 days ago. Aug 30, 2019 - 14:53 BST
Investigating
We are currently experiencing issues with our systems which means members are unable to reinstate or renew online or over the phone. Our team are investigating the problem currently.
Posted 18 days ago. Aug 30, 2019 - 14:48 BST