Login Issues
Incident Report for Spotlight Service Status
Resolved
This issue has now been resolved.
Posted Nov 22, 2020 - 17:57 GMT
Investigating
We're aware that some members may be having issues when signing in to Spotlight. We're working on resolving this issue.
Posted Nov 22, 2020 - 17:33 GMT