Spotlight Services Down
Incident Report for Spotlight Service Status
Resolved
Spotlight services are back up and running
Posted 12 days ago. Aug 13, 2019 - 12:31 BST
Identified
We're aware that our systems are currently down. Our IT team are working on this as a matter of urgency. Apologies for the inconvenience, please bear with us.
Posted 12 days ago. Aug 13, 2019 - 12:19 BST