Delay in breakdown emails being sent
Incident Report for Spotlight Service Status
Resolved
This incident has been resolved.
Posted Oct 14, 2020 - 11:49 BST
Identified
We're aware of a slight delay between emails being sent out via our platform. This will be resolved shortly - in the meantime, please check the Spotlight Link.
Posted Oct 14, 2020 - 09:10 BST