DB Downsizing
Incident Report for Spotlight Service Status
Resolved
Maintenance work is now complete
Posted Nov 24, 2020 - 23:14 GMT
Investigating
We are performing some essential maintenance that may cause some disruption to services. We expect this to be complete 11:30pm Tuesday 24th.
Posted Nov 24, 2020 - 22:58 GMT